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Preface

Indian Geospatial Market is on the verge of a remarkable growth. We are witnessing huge
growth spurts; companies are bagging of unprecedented scale, In the early 1920s, most indian GIS
companies relied on outsourced business from overseas market with US accounting for bulk of
business followed by UK/Europe. Indian business used to account for a marginal percentage of the
global business. However, trends are changing and so is the equation. Business in the Indian
market is increasing and what is noticeable is a fine geographic mix of business. It is a welcome
change, albeit a bit slow

Mow the momentum is picking up and all the rhetoric is transforming into reality. This is largely
due to government focus on use of Geospatial technology and large initiatives for its implementation,
Such initiatives will give effective results only when an effective enterprise GIS system is deployed
by the organization at National, State and Local levels,

Geospatial Technology is relying increasingly on digital spatial data acquired from remotely
sensed images, Photogrammetry techniques, and analysis by geographical information systems
{313) and visualized on the computer screen or on paper through Geeo-engineering, This focuses
an the application of (30) Geospatial Information Technology (GIT) in a Geelogical, Engineering and
Geo-environmental context.

To optimize the use of technology, additional capabilities must be available, such as a thorough
understanding of Remote Sensing & Digital Image Processing, Photagrammetry and GIS. The
extraction and analysis of Geospatial information from the GlS-based integrated systems are used
in various industries such as Petroleum, Telecom, Civil, Constructions, Economics & Finance,
Marketing, Agriculture, Geology, Geography, Health, Utilities, Envirenmental medeling for planning
and execution to a variety of end users for decision making purposes. Therefore, Geospatial

Technology is no longer a tool for the specialist, but is a decision making tool for the management,

Demand for Geospatial Technology has skyrocketed over the past few years. By linking
geographic data with demographic information and business intelligence, organizations are finding
new applications for Geospatial technolegy. In order to meet the huge trained manpower requirements
for the Industries, itis recommended to introduce the technology at secondary level of education in
the country. GIS applications are now regularly used by both private and public organizations of all
sizes, which have generated more demand for GIS professionals.
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Increased demand for GIS services has made solution providers like ROLTA to evolve a fresh
approach to how people find, analyze and use GIS information and structure a vocational education
and training course aiming to educate students in the field of Geospatial applications using Remote
Sensing, Digital Photogrammetry and Geographic Information System (GIS).

This vocational course offers professional education dealing with mapping and Geospatial
production to ensure that students obtain insight into Geospatial database concepts, creating and
implementing databases, spatial analysis, developing GIS applications, through both theoretical
concepts and supported by extensive practical exercises with hands-on training using Rolta

Geomatica industry standard software.

it is hoped that this curmiculum would help a large number of young Indians to acquire employable
skills and to enter professional world for them to earn decent livelihoods and to aide economic
growth of the country.

Vineet Joshi
{Chairman)
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THE CONSTITUTION OF INDIA

FREAMELE

WE, THE PEOPLE OF INDIA, having sclarnnly resolied 1o constiite Indla nto a ¥ [SOVEREIGN

SOCIALIST SECULAR DEMOCRATIC REPUBLIC] el 1o secure 1o all s citizens -

JUSTICE, sccial, acemamle and peliizal,

LIBERTY of thaught, mpossion, keled, falth and wordin:

EQUALITY nf status and of npparmity, and 1o promole arwrg Beon all

FRATERNITY assuriig the dianity of the ndividial and the ¥ [unity and tnbegrily of the Mation|

N OUR CONSTITUENT ASSEMBLY this twenly sixth day of Movembar, 1949, co HEREBY ADOPT, ENACT
AND GIVE TD OURSELVES THIS CONSTITUTION.

T, SHubs, by fea Constiubion Torly-Serond Amendment) Act. 1976, sec. 2 for "Srvercion Demoeratie Hepublio
fward. 31,1977
- Sube, by the Conslilulion Forty-Serond Amendment) Act 1976, zor. 2, for “uig of the Nation juw.e.f
311977
THE CONSTITUTION OF INDIA
Chapter IV A
Fundamental Dhnties
ARTICLE 514
Fundamental Dutles - Tt shall b (e duly of every cfizen of India
) o abide the Constiluion and respect s ideals and institvtiors, the Mational Flag and ihe Naional Antherm:
o) to cheriah and follow the nebile jdedls which inepired our national stuggle for frasdon,
fe1 o uphold s protact the souendanly, imlsy and insegrity of Indis;
fd) o defend the codnmy ared sender national service when called upon  do s
fed  To promnte harmany and tha spirit of common brotherhood amongst all the people of Indla transcending
:C;hj:mzf: brguistie ard regicnal or siclional divessities; to renounca practieas derogateny to the digrity of
(i oo vahin and proserst s rich heniage of our composite culong:
(@ e perotect aned i e nalurel envivonment including favesis, Takas, rvers, wild Tfe and to Teve conpassicn
far Ihlng arasfirms
) o dirvalop the scleniiine fenner, Lumarism ond e spirde of inquiny sl loan,
o safequard punle poopeny ml b objure violence;
o strive towards exeellence i all spheres of indiadual and colleetive sclivily so sl The nation constanty raes

fn hlghwar loveks of eakesvuur and achisvernend,
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Exercise-1

Aim: To Understand the Projection, Georeferencing and Subsetting of the data

1. Todisplay Raw Toposhests or Images

2. Todisplay Georeferenced Toposheets or Images

3. Togetthe coordinates of Raster and Vector data

4, Tofind the location of any Point with co-ordinates

5.  Tocreate the subset of Raster & Vector Data
Required Datasets

Copy all required dataset from datasets folder of this practical session to your local hard disk as
menticned below:

1.  Toposheet - 45D14 tif (Registered or Corrected)
2. Image - Mount_Abu tif (Unregistered or Uncorrected)

Sofiware Used:

Rolta Geomatica Prime Software

Procedure
Geo-referencing

From the Start > Programs list select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Toolbar will be open, Click on Ortho Engine tool.

¥ Geomatica Toolbar ¥10.3.0 =113

Or OrthoEngine can be invoked from Windows menu, select:
Start > Programs > > Rolta Geomatica > OrthoEngine.
3 Starting a Project
Click on Crtho Engine File menu and click New.
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Enter Filename, Name and Description in Project Information Dialogue box and click OK as shown
below.

& Orthok ngine: = DI
Processing step Y
Sel general propect nformation
:: Projec! Information ")(

Flename  |new py Iml
e [Hews Promct

Ciescnphon |

M ath M ockelirg Method

7 Al Photogaghy

™ Dptical Satelite Modeling
™ Flade S slelite Modeling
= Pokymaorel
T Plate Sghre

™ None [mosss: only)

@1 ok | Cocel

i.  Settingup of Projection parameters as given below:
s  Choose Lat/Long in Output Projection.
s  Select Earth Model to Geographic \WGS84

»  Enter Output pixel spacing as desired (For Example: 1:50,000 scale map sheet it
should be 0.6 m). Units will get automatically changed based on selected Earth
model.
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e  Change Long/Latin GCP Projection & Earth Model,
s Click on Set GCP Projection based on Output Projection to set/apply the parameters.

. Click Ok to close the window.

= Set Projection

Dutput projection

[Long/lat ~] EutthdaL.“LElNGMT D000 - |
Output pesel spacing: | 0d3600.0000° Deg

Output fine spacing: | 0436000000 Deg

GCP Projection

[Longlat ~] EaﬂnHod&L.IILDNGMT D000 _|

St GCP Piowaiion based on utput Pioction]

@? ok | cancel |

ii. ~ From the drop down list in the Processing step, choose GCP Collection

ALY
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Click the first tool (i.e Open a new orexisting image), Open Image dialogue box will open.

(3) Unconected images () Comected images

Select Uncorrected Image option & Click on New Image to choose the Uncorrected
Image from the path.

@ Uncomectedimages € Conecled

? This raster data does not have piebull ovenisws
which will enhance display performance.
Do you wish lo creste ovenaews now?

o] ]

@7 Ouck Open| Quick Oper I |.'.. i | ]

If the raster data does not have prebuilt overviews, then click yes to create overviews.
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2 0pen Image r?|

@ Uncomected mages Conected mages

1Mount Abur D:ACBSE Exsicisa‘\Exercize 4\1Mount Abu td

@7| 0uckOpen| OuckOpeniCiose|  Open | Mewimage|  Cioce |

After creating overview, selectimage in to window. Click to open the file.

Select the Mount_Abu tif file. Now the open tool is active. Click open. A box will come.
Click default, Load & Close.

& Viewsr: kmags 1D: 1Mount_Abu rcise_ 4V Mooni_Abu. Hi
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iv.  In OrthoEngine main panel, click 2nd tool (Collect GCP manually), GCP collection panel
will come

%% OrthoEngine: New Project

File Utiities Options Heip

e o S
45010

Collect GCPs Manualy

Locate GCP first on unregistered image (Mount_Abu. tif), then on corrected image (45014 tif)
manually at same location. Similarly collect minimurm of @ to 10 well distributed points on both the
images. To improve the guality collects more points with more accuracy.

v WL @ O D SO B i )
W T

[ mTee AamN maEsanie e
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panel.

3 Ltiities Options Help

Processng ttep .
|GCP Colection =l

Project saved

Close the image viewer and GCP collection panel.

Select Geometric Correction tool from processing step drop down menu,

2 Rolta OrthoEngine: New Project
Fle Utibies Options Help

e 8

CP Colection

o] =
.8

[F
epoits
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Click 1sttool and open the Mount_Abu. tif file again.
Go to the 3rd tool Schedule geometric correction.

2= Orthof ngine: New Project

Fie Utities Options Help

Select the available image in the dialogue box & keep all other defaults. In corrected image browse
to give an output file name.

& Geamelric Correcled image Prodection

Eerunye boeahon bor Thlound_dby

Ursterec b Image Comeeted bnagys

Image O CBSE_Esewe \PMourt_sbu Fie [0l Mourd_abupe Mﬂil
Stahus: Model Lolo-dute Stabus No ot gerenaied

Input channely. & AT} Poews i wll be CREATED

T Crennes [

Soe 3 BSHI0S x 2T B b (14027 M) € ciomale]

I Apply gt charnel ssloction e sl Hes

Lowss ittt [1BEE2E 75 E X[ 148555 ¥ n.mw.|
Comecton Dplerms
Procesang Dptorn Praceteng Stat Tme
| Woingeache [T -] Milyees M St roms

[ E—" Samplegrteret T 4 ™ Ghat of [Hvmen]
— Fesarpirg  [Hemeu =1 I :jr“jﬁ
1 r

e C 8 =)

"

Click Correct Image. Geometric correction progress window will come with task bar,
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& Geomelric Correction Progress - O

Procestrng enage 1 oun_Al Tl

Generating Ortho for mage TMount_Abu

Giermiatng Ortho for image TMourt_Abau
Craating o Meunt_Abs pis

"~ Geomelric Correction Progress

Procesung mags 530-14-5W_HN Tal
Gensiating Otho for mage 530-14-5W_N BA% complete

Generating Drtho lor mage 53D -18-5W_N
Creating D \Mew Folder\Fegrtrabon \geo til

On completion of the Geometric correction the Geometric correction dialogue box will come again,
Save the projectin the OrthoEngine main panel and close OrthoEngine.

Mow open the corrected . Pix file on the focus viewer to check the georeference.

Reprojecting data
Reprojection Tool is used to change the projection of any data to ancther defined projection.

From the Start > Programs list select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Toolbar will be open. Click on first tool “Focus” of toolbar to open
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Or

Focus can be invoked from Windows menu, select:

Start > Programs > > Rolta Geomatica > Rolta Focus.

&2 Geomatica Toolbar ¥10.3.0 EI@'[E

&l W B s

Fle Edt View Layer Andysis Tooks Hep
DSHES E= 008 X E|« [T

R~ h T %87 028 % 2~

Maps I Fles |




Go to File menu and add to select the file which need to be reprojected, For example 45D14 tif

L [P S ~mem
S D
X . ginta
= - AL
[ g, Eerre
& ki e e
LR fees Fo )
fA 05 . B2 Lomiegy
L0ty .
=
L] [P
e ]
oy (s
Nl || fE = [ o= ]
il i T 3| e
_“Dﬂ Do Doy i e

Click Open.
File will be displayed in Map Window as shown below.

Fie [ Ven Lo Took Fwin

D= 0B XKD |« ~ ﬁ.ﬁl@@ﬂﬁ@bomliﬁ
Rer Me-T LR 2-T2-3-L-T-%-0-L0-F8|
Maes | Faes | =4 :

I Mew Avea
R, PO EFE
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In Rolta Focus window, from Tools option select Reprojection tool.

Tools > Reprojection

DSESREs smmen-  Blo o HE o o
K=b p-T 'ﬁ'f-il Raster Caloditon . S = S ¥t i
Mape | Fies | | Databioroe i
| peecmion. |
B [ =w - — .
w2 YV 4s014] :;::
| Dpten.,.

Click browse to give the Deastination (output) file.

[ (R

Frossm | “eimasce fee O CESE_ L mevooan'i soal CHSE T mendin_SONE mesme_ Tl 4 W

x|
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Window also gives information of existing Projection system of the input file.

4]

1] Heprojeci

Broaven | Source le DACBSE_E swcae'\Fing (BSE_Esecie YONE sercas_ PASD 1AM
Beowon | Davtrabon bl |0 \CBSE _E wescs\bopsomcinm et pe

Outiput format

== =] Dptons | lJ

[Use prnlefines anclbeunds =

Soe (2219 Pok (2550 Lres

Poel Sue [ 000005007 % [ OaOCOOOSODT ¥
ESSEEN -] eatodd | TOWGAAT D00 _|
Bunde  [Gecgmhe =]

UppesLadt | 7242598500 Long | 2406654 TSOO'N L
Lows Right: | T301295000T  Lomg | 2442647 500N Lat

Puel Son . 1 33683005 dogroes
Poel Scn'v. 1 19683005 degroes

Resamping [Neaew =] Transiomn Order [Eaacy +| Samging ietervat [

Vew[il =] Selctal ﬂ:l_,_l

L[ aul Contents Not Specif
2 [ Bu Channel 2 from D
3 [ 8u Channel 3 from D *
1 [GED]| Georefersnce segnen
i [GEO

Naster Georelerenci I

@1 Smpe | _Ome |

Crop down the menu next to Earth Model & Select UTM in place of Long/Lat & accept. For datum
choose WGES84. Following parameters need to be entered.

UTM as a Projection
W(GES 84 as an Earth Model and accept it
Zone 43 as a UTM Zone and accept it.

Row T as a UTM Rows and accept it.
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P |m-nmwwu
— |u--h{o-uu,l—-ﬂ-———_—

Cnga —
| T

=] Dgtewa | g |
[y re———

foe TN P [ Leem
Foutloe | DECO LT | GEETOOMET W

Zone 43 as a UTM Zone
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After selecting all the parameters, click on Accept button which shows all the layers at the bottom
of same window to select & add to Destination layer.

n Reproject

Browyze... | Source file 0ACBSE_Exercise\Final_CBSE_E wercize_MINExercize_ 38450014 b

Browse... | Destination filufD:\CEI5E_Endcise'uupmiuﬂnun\tusi ik

Dutput format

[PEcPEs | Optionz: | ?_J

M sximeim Biounds

|Uze piels/lines and bounds -
Sie (22193 Piksls {26550  Lines
Prel Size: [1.3782 w 15867 ¥

I |UTH 'I Earth Model... IUTM 43 T Doo0 Hurel
| Bourds; Geogiaghic =]
Upper Left: | T2ddZ53 8500  Long | 2444654 7500 Lat

| Lower Right [ 72001295000 Long [ 24d2447.2500N  Lat
Poeel Size X: 1.3782 METER
| Fiyel SizeY; 155571 METER

Resampling |MNearest » | Transtomm Ordes m Sampling Interval fli

Seleciable Lapers

| Saurce [ayers i i LA
View [21 -] Ef_'len{ﬂ.lll :]ﬂ . I e I

t Specif
> from D:
ron D

segnen

ferency s Add >
< >
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£ Reproject El

Browse. | Source e[ ACBSE_Exercize\Final CESE_E wescize XI\Eweiciss 3045014 1

Browss.., | Destination fie:]D:‘\.CBSE_Emrcise\tepaiedmn\.test.pbe

Output fomat:

{Pl=PE = | Options: | lJ

| e pixels/lines ard bounds =]

Size 122193 Puwels [26550  Lmnes

Pinsl Size: |1.3782 % [1.5867 i

[0TM =] EathModel. | [UTM 437 DO0O M;xe.‘
Bounds: W

UpperLeft: | 72d42'588500°E  Long | 24d46'54.7500°N  Lat

Lowet Bight: | 7380123 5000°  Long [24d2447 2500°N  Lat
Pivel Size X 13782 METER
PixelSize Y, 1.55671 METER

Resampling |Mesrest = | Transfom Order; IEHa:I = | Sampling Intesval |4

Sousce Layers Destination Layess

View [All x I Sefect All

21| Repoject | Ciose

Click on the Button reproject.

On clicking reproject process progress monitor will show the process.
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Output format
[PECPIX -1 Dptions: | 2l

Repromchon Bound

[Use pivelsfines and bounds = |
Ske [22193  Pieels (26550  Lines
Pieel Size: [1.3762 ® [1.5867 ¥

UTH =| EathModel.| [UTM 43T DODD More:

Resampling |Mearest = | Transhorm Order. IE:nu:l = | Samplng Interval !ll

Destination Layers

o Bl

Using this function we can re-project georeferenced Raster as well as Vector data to other projection
system.




Subset Creation

Subsetting data are effective methods working with large data sets. By working with small
representative areas, you can reduce processing times or you can use file subsets to test an

image process.
To create clipping of Subsetting:

Start > Programs > Rolta Geomatica > Rofta Geomatica. Open a new project in Geomatica
Focus,

Add image for example Mount_Abu tif to the project by using file menu
File > Open > Mount_Abu.tif

]

DeHdf~ 0B ERE « -EadcSHCcELweTUF
Nk BT Gl - L N LT O -l
Bl = 1

et
S ko i 010

-
T e T T
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Procedure

Go to Tools menu, select Clipping / Subsetting, which displays a window to select clipping/subsetting
options. The clipping option of Geomatica Prime is shown below,

-

User-entered-coordinates.
Selectafile.

Select a clip layer.

Select a Named-Region.
Select a Script-Subset file.

Use current view,

Below method explains how to subset the input data by Clip Layer method,

1
2
3

Go to New area, right click & then click on New Vector Layer,
Choose whole polygon option in layer type.
Click OK.

. Pt s Sy gy | frv— iy

DSBEE= o X <~ HadsclIsBLeMmURF-
L B A RS R e S P S el B RE D
Mo [ 1 | | [ = ==X

il P il 1,29
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Save the whole polygon. Right click on whole polygon, a Mew Item Detached window will open,
Click on Browse option & enter output file name and path then save.

Create a polygon on image: Go to view, Toolbar & click on editing toolbar. Select polygon layer as
shown below:

Fia B Vew Gaye dosirss e
N@AST=e08salv - HdecloBLOB IR
RO TEEAR-F2 a-ET 0B

wee | Fies | -

= [ W Aina
2 e suhaet] 2 How Wihole Pl
e M T bt 1 23

Tl

w [ 7aeres T Madin T

For clipping of this part of image

Follow the following steps :
(i} First select the polygon.

(i) Then go to Tools, Clipping/Subsetting. A window named clipping Subsetting will appear, fill all
the required parameters and click an Clip.

{iii) A window progress monitor will open, which is showing the progress of the clipping activity.
{iv) To verify the output file use the file menu and add the clipped file into project,




Practical Manual Geospatial Technology - Class XIl

rwmEbeseeEd Lol R

al | L] |]
|
e T

Jaith [ Fhaiirs e akris um

- - Ty - -

L]

Creating subset using Select a Named-Region method:

For this method first we need to create Named-Regions. For that from View menu in main toolbar,
select Named-Region as shown below:




Select any area of image which you want to create as one region.

iAecEHIB o il
Lo oot dn- i

THIT0 b T

Open Named-Region window, add and rename it as per your choice. For example.
N_A, N_B,N_C,N_D.

D@ onm@*»ahi - -RAd®SEOELOELRP:
L D - S O el S R el s el

s | s |

-
[Tamm 04100 Tam  wiramiang s e Bl e
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Then go to Tools in main toolbar & select Clipping/Subsetting tool after creating regions as per your
requirement. Clipping/Subsetting window will appear. Give current image as input & enter output
file name. Definition Method will be Named-Region. Give any Named-Region which you created
earlier. Forex. M_A, N_B. Click on clip and it will show progress monitor process,
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Exercise-2

Aim: To create the GIS Data
1. To Exiractthe point, line and polygon features
2. ToBuild the topology
3.  To Build the various gueries

Reqguired Data sets
1. Images- 45D14.tif (registered)

Software Used:
Rolta Geomatica Prime Software

Creation of Vector data
. First we need to open Rolta Geomatica.

»  Geomatica Focus will open automatically.
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Add the registered tif (45014 1if) to the project for digitization through open option from File menu.
Save the project with proper name.

‘You can create a new empty vector layer to use digitized map information, break your map into
different layers with specific geographical information, or when you want to create vectors on top of

an image in the view pane. Add the layers like Point, Line, Polygon and text with option of topelogical
Line and Polygon options,

e e -

o [ Ty [T

Right click the new area & click on new vector layer.

£ New Vector Layer E|
Layes Type
 Unshuctured ™ Porl ~ Line
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Select Topological Line, Point and Topological Polygon from new vector layer to add to map window.
Rename the layers as required.
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After adding the layer to map window we need to select line layer from New Shapes.

Capture roads, streams as line features, Water bodies, Ponds as area features. Temples, Buildings
as Point features from the image.
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Qutput results will lock like as in given below window:
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Editing of Features: \We can edit the features by selecting the Editing tool, if any corections required.
First select the feature & click on the vector editing tool to modify the existing / created feature.
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Use Vector Editing tool to modify the existing vector information. Some of the vector editing tools
are shown below:
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Building Topology

After creating and editing the vector data the topological errors need to be corrected. The procedure
to do this task is define here.
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Go to Tools menu and select the algorithm library

Find & Open VECCLEAN Algorithm.
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We need to set the parameters (Tolerance) for Overshoot, Undershoot, Merge, Break, Remove
Nodes and weed under the Input Params 1.
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Set the parameters for the VECCLEAN algorithm as shown below and click Run. Check the log for
Successfully completion of process.
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Results will display corrected topological errors like undershoot and overshoots in the Map Window.
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Thematic Map Creation

After creating, editing and correcting the topelogical errors, the data is ready to generate thematic
map. Right click on feature & select Representation Editor. Choose Edit style and define the primitive
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option (Polygon fill for Area Feature, Line Solid/Dash/Dotted for Linear Features) and define the

color as per requirement to depict the thematic map. Given below figure shows the thematic layer
for buildings as Polygon and Road as Linear.
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In case of Point Features Choose Edit style & define the primitive option as Point Symbol. Now in
SymbollD choose pre-defined / customed symbols for Point Features. Like Temple symbol for
Temple features.
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Query

A guery searches and selects records that correspond to a set of criteria that you define. There are
two types of query: Spatial query & Atiribute query. With the help of query, we can highlight the layer
of our interest. For example if we have 10 to 15 buildings having different names, we can find &

highlight the building of specific properties based onits attribute data.

Example 1:

1. Openanew unnamed project. Add all the vector layers into it and save it.
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2. Open the attribute of the vector layer by right clicking on the layer.
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Attribute Manager Dialogue box will open.

Here we have buildings name with Type A, B, C, D etc.

If you want to see all the buildings with Type A, then highlight any one of them from the map,
Go to Spatial Query window & select query by example.

Query by example dialogue box will open; Select Name in Attributes box and Attribute
Value as per requirement (For Example A to display all the Buildings Naming with A
Attributes).
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B Query by Exampbe - building : building
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8. Then click on Add & Apply & OK.
9.  Now all the building with type A gets highlighted.
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Spatial query toel can be select from the tool bar as shown below:
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Example 2: Let's find Temple with the name “Dilwara Jain Temple”

Right click on Temple layer.

Open the attribute of the vector layer by right clicking on the layer.
Attribute Manager Dialogue box will open.

Ea

Suppose if we want to see the Temple with the name "Dilwara Jain temple”, go to Spatial
Query window & select query by example.
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Query by example dialogue box will open; Select Name in Attributes box and Attribute
Value as per requirement,

Set attribute as name, select Dilwara Jain temple in Entry List,

Then click on Add & Apply & OK

Now Dilwara Jain Temple will get highlighted.
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Similarly, if we want to find out the lake area equal to 2642 .42, we can build query based on area
from Mount Abu map. Select Water Body to build the query as below,

i Query by Feample - Waier _Body : Waier Body
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. Select area as attribute and attribute value from entry list, add it in new statement, click
on apply & OK.
. As result we can see the |ake equal to 26462042,

Result:
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Exercise-3

Aim: To understand and perform the Classification for Satellite Imagery
1. Toperform Unsupervised Classification
2. Toperform Supervised Classification
3. Toknow Histogram Modification
4,  Toenhance theimage by spatial filtering

Required Datasets
Images - Mount_Abu_Reg.tif (registered)

Software Used:
Roita Geomatica Prime Software

Unsupervised Classification
From the Start > Programs list select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Teolbar & Rolta Focus will be open.
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Go to Analysis > Image Classification = Unsupervised Classification,
Open Mount_Abu_Reg.tif Raster file in to PIX format.
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After file will open, it displays Session Selection window where we can create a new session
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On choosing Mew Session, the new Session Configuration window will open. Here we need to
configure the parameters:

e Inthe Description box, type Unsupervised Session.

. Don't change the Red, Green, and blue color values.

e  Using Add layer button add 3 more layers (Max. Limit of adding layers is 30).

. In the Input Channels column, select channels 1to 6.

¢ In the Output Channel column, select channel 7. This channel will store Output

classification results.
. Click OK.

R Session Configuration
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@ Session Configuration

Desception: | Aok Lawss . |
Irpud | Dusput
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New layers will be created. Click CK to close the window.

MNow Unsupervised Classification window appears where we can set the parameter like Number of

Qutput Classes, Ilteration value ete. Click Ok to run the process.

n Unsupervised C

lassification

Algorthm: K-Means parameters:
& KMeans Patameler Value
™ Fuzzy K-Means Max Class 16
" lzoData Mae lerstion |16
Min Thieshold | 0.010000
Bl s © o Gl 2007 42
Clazsification Oplions
W Shewiepoit [ Savesignstwes [ Ciesle PCT

Use bitrap a: mazk

e =]

o LI




Practical Manual Geospatial Technology - Class Xl

On completion of process, the Progress Monitor will close. Classification Report will open and the
classified image displays in the Focus view area.
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Output of Classified Image:
m
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Supervised Classification

From the Start > Programs list select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Toolbar & Rolta Focus will be open.
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Go to Analysis = Image Classification = Supervised classification
Open Mount_Abu_Reg.tif Raster file in to PIX format.

After file will open, it displays Session Selection window where we can create a new session, Click
on new session, and create new session
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© Session Selection
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On choosing New Session, the new Session Configuration window will open.
In the Description box, type Supervised Classification,

e  Beside the Description box, click Add Layer.

*  TheAdd Image Channels window opens.

. Add two B-bit channels (First channel will contain training sites, the second will contain
the supervised classification result)

* Click Add. The channels will be added to the _pix file.

4 Session Configuration .:.LE_U.EI

Input | Trairing| Oulput
Channel £og GmuJE&n:Ehurtk Channel 292 Channels
o

10 v |band 1
2 1 f— | {band 2
3 1y | . ! \band 3
LU | | {band 4
she P ] band §
& | band 7
7 = = _ B (K-Means Unsupervised ===
8 | | Aggregation result from Channel 7

= i
@1 Ok, Concel | Fee | Sessions. |

. Select channel 1to 4 as Input channels, 5th as Training channel and Channel 7th will be
for Output. After configuring click OK.

1] Progress Monitor
Adding 2 unsigned 8 bit channels. ..

The Session Configuration window will close and the training site editor window will be open to
classify the new required classes as well as their colors.
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MNow mark some training sites of given classes by using the trace polygon as given below
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Click on class option of Training Site Editor window to add new class and assign desired color and
name.
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After editing, save all the Classes and close Training Site Editor

Right click on Map Window legend entry & select Run Classification. Supervised Classification
window will open, set the parameters as desired and click Ok.




Practical Manual Geospatial Technology - Class Xl

£ Rotti foces  Unnaswd Project  Claniificatos Mg

Mo 18 e o e bk o -
DSHSdR~ 0B n HAMCEHOBLODNR:
A orQ-T OB 252201 L-0t-30-90

H-|ﬂnl| ! 'y

) Vi st i
1 W s
.“m
il Tomrarsy @z bt
#@ B eotigmn e
LR Y Caositas
(£ L sl
e S i o e
Lrdews
e Y ]
g Lot vt [ Lbunil o af ins
hayvie iyl 0w
& Pyakipoed o et M L s e e
e Darwvn
7 M L sitood
Llne e e g

 Boswmpet W Semspiem [ Qe PO

Lo by b0 == |

o o | e |

Progress bar will come to show progress of process and generates the Classification report. On
completion of process a Classified Raster data will be open in Focus window.

Save the file by selecting desired output format and name.
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Output after Classification
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On completion of process, the Progress Monitor will close. Classification Report will open and the
classified image displays in the Focus view area.
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Image Enhancement

Procedure

Start > Programs > Rolta Geomatica > Rolta Geomatica. Open a new project in Geomatica
Focus,

e‘ Set ProgramAcomss and Defalts
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Add existing raster file to the project by using file menu
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Then go to Map view window, right click on the layer in legend window. .

Select enhance to maximize the various eptions.
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Enhancements make the image on the screen clearer and easier to interpret without changing the
values in the image file. The following section describes the available enhancement options.
None: This setting applies linear stretch or a linear enhancement to other data types using their
pixel values. The stretch is applied using only those pixels displayed in the viewer. With this option
we can also remove prior applied enhancement from the image.
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Linear: Uniformly stretches the minimum and maximum values in the image overthe entire available
output display range to enhance the overall differences in gray levels in the image.
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Root: Compresses the range of higher values (brightness) and expands the range of lower values
{darkness) so you can distinguish more detail in darker areas of an image while still retaining some
detail in the brighter areas.

T B W b A B P

DeEa = & DB R -
(8 e T Ly
W | Wi |

O eoEOE oI i F-
. % L R S e ety R

= Hin T




Practical Manual Geospatial Technology - Class Xl

Adaptive: Combines the benefits of Equalization and Linear enhancements resulting in a more
natural display than Equalization while effectively compensating for outliers.
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Equalize: Distributes the values equally over the entire output display range resulting in an almost
uniform histogram. This enhancement is effective in exposing details in the higher values (brightness)
and lower values (darkness), but causes less contrast in the middle values.
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Infrequency : Assigns the values that occur the least frequently inthe image to the range of higher
values (brightness} in the histogram so finer details become brighter.

DawHa: e XRhE v FHOoaeoEORL.0oMHP-
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Tail Trim (togale): Omits the upper and lower 2 percent of the image histogram to remove cutliers

in the upper and lower part of the pixel range. Tail Trim uses a 2 percent margin by default, but you
can adjust the amount of tail trim from 1 to & percent with set Trim percentage.

Exclude Min/Max (toggle): Disregards the lowest and the highest value in the image histogram
before applying the Tail Trim.
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After applying the settings click on Save As menu to save enhanced data orimages.
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Enter the output detail using browse button to save in desired location. Choose desired output
format by drop down arrow in Format option, Click on properties button to define Output type &

scaling in Output Layer Properties.
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Select New layer fram Output look up Table, and save the default lookup table. Click Ok to save.
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Spatial Filter
Spatial filtering is defined by:

(1) A neighberhood; (2) An operation that is performed on the pixels inside the neighborhood
Spatial filter will be used to get more clarity and sharpness an the images.
Procedure

Go to map view window select the open layer and night click on it, Select the filter option.
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A new window will open. Select the option as desired.

By default Low Pass tab with average filter option is active. Along with Average filter, there are other
Low pass filters available to select as Median, Mode, and Gamma.

Enter the value for Number of looks & Select Image format.

Click on apply to view to view result. Click on Apply to file if you want to apply the result on file.
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» Filter: Cut_N34_E74_Relief.1if:1,2,3

frea of Interest

Mask: Entiie raster v |

Fiter sizeX: 3 -~ J Al E -
Low Pass | High Pass | Custom |

Filter:

(®) Average
) Median
O Mode
() Gamma

Cumrent view fiter; Mo filter

(@7 oo toview] || e [4pplytoFle| [ Close |

Zoom in the selected image to see the filtered resulis & effects. The filter can suppresses the
image speckles, but the same time linear details can be preserved.

Mote: You must enter correct image mode values for the image data files you are working with. The
number of looks and the image amplitude information is available in the format definition of your
data.
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% Filter: Cut_N34_E74_Relief.tif:1,2,3 =13
Asea ol Interest
Matk: I_Entimraslu v |

Fites size 2 g | Y 12
LowPass  High Pass | Custom |

Fiter

() Gaussian(SIGMST = 4]

) Tvpe 1 - Laplacian Edge Detactor
) Type 2 - Laplacian Edge Detactor
() Sobel Edge Detector

) Prewitt Edge Detector

() Edge Shapening

Cuntert views flter No filter

5 S o [

In High Pass Filter option following types of filters is available:
*  Gaussian Filter (SIGMSQ = 4)
* |-Llaplacian Edge Detector Filters
s |I- Laplacian Edge Detector Filters
s  Sobel Edge Detector Filter
*  Prewitt Edge Detector Filter
s  Edge Sharpening Filter
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On selecting the filter option, give path to create new file/layer or save in same layer,
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Result of Gaussian filter is as below:

Before filtering Enhanced Image After filtering Enhanced Image

Similarly, do the exercises as per requirement for different type of raster data and save in new file,
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Exercise-4

Aim; To Understand and perform the Spatial Analysis
1.  Toknow Buffer Analysis
2. Tocreate Dissolve Boundary
3, ToMerge the data

Required Datasets
1. GIS data (use all the vector layers from Datasets folder)

Software Used:

Roita Geomatica Prime Software

Buffer Creation

A buffer is a margin created at a specific distance around shapes on a layer. You can create
margins of different sizes, each referred to as a buffer level. You use buffer levels to analyze
suitability or risk around the input shapes, which is referred to as a proximity analysis.

Buffers can be created for lines, points and polygens, Forexample, you can create a buffer around
domestic wells to analyze the risk of contamination from pesticide use.

Procedure

From the Start > Programs > select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Toolbar & Rolta Focus will be open.

Click on Focus tool from Geomatica Teolbar.
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Browse for the existing project to open the vector file. From the Analysis menu, click Buffer,
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Creating buffers - step 1
1. Inthe Input area, choose a file from the File list box. If a file is not listed, click Browse,
locate and select a file from the File Selector window, and click Open.
2. Choose alayer from the Layer list box.
In the Output area, enable one of the following options:
. Display: shows the results without saving the new layer

*  Save: saves the new layer to the project. Choose a file from the File list box and
choose a layer from the Layer list box.

*  Ifyouwant to display the results in the view pane, enable the Display saved results
check box.

+  Ifyouwanttoinciude only the selected records in the layer, enable the Buffer selected
shapes only check box.

4, Inthe Buffer Distances area, enable one of the following options:
»  Simple: buffers all the selected shapes

=  Representation Values: buffers the selected shapes according to their representation
values
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e Field: buffers the selected shapes according to an attribute. Choose an attribute
from the list box,

Enter a number of levels that you want in the Buffer levels spin box.

Choose a unit of measurement from the Units list box.

In the Buffer distances table, type a number in each Level column to determine the width

of a buffer.

Click Next,
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Creating buffers - step 2

1.

[

In the Vertex Options area, enable a cornering type.

In the Line Options area, enable an option for the side you want the buffer to appear,
Enable an End style option for the style you want to use at the end of lines,

In the Polygon Options area, enable a style option.

In the Fields to Add area, enable the Source Shapeld check box.

Enable any of the following check boxas:

[attribute name] Value: includes the attribute values in the output layer if the buffer is
based on an attribute and if overlapping buffers are kept

separate
Buffer Distance: lists the width of the buffer for each level in the output layer
Buffer Level: lists the levels in the output layer
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7. Inthe OutputAreas area, enable one of the following options:
. Combine: combines the shapes where the buffers overlap
*  Keep Separale: keeps each buffer separate

8.  Click Finish.

If you want to save the result you can define the output path and file name.
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ﬁ Bulfer Wizard - Step 2 of 2 - Output Optioms 1"*'
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After changing Line Options Both sides - The Output is as follows,

Similarly for Polygon we can generate buffer as given below. Select polygon feature activates the
Palygon options.
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B Buller Wirard Stap & of 7 - Ul put Optians
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By this way we can create buffer arcund the vector features at required distance, the use of buffering
varies from feature to feature -

River buffering — Give Catchment area Information up to given distance.

Building Buffering — Give information for the planning of road network up to certain distances.
Road Buffering - Create a buffer around the major highways to identify zone for the cost-effective
transportation of goods.
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Dissolving Boundary

Dissolve combines shapes that contain the same value for a selected attribute. The resulting
output is a layer that contains the newly combined shapes with each shape represented as a layer
record,

Steps:

1. From the Start > Programs = select Rolta Geomatica » Rolta Geomatica, Rolta
Geomatica Toolbar & Rolta Focus will be open.

¥l Geomatica Toolbar ¥10.3.0 EHEWE!

Click on Focus tool fram Geomatica Toolbar.
Now open any Raster image from local disk.
Now create a new vector layer to draw the polygons. Right click on the new area & click

on new vector layer.
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5.

6,
7.
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A New vector layer window will open, click on Whole Polygon & click Ok.
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Right click to save the new vector layer.
A window 'New Item Detected' will open.
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Click on Browse. Now it will ask for the path where you want to save your file, give path
& file name & then click on Save as.

From the Analysis menu in the Focus window, click Dissolve.

In the Dissolve window, choose a file from the File listin the Input area.
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11, Inthe Qutput area, enable one of the following opticns:
+  Display: displays the results without saving the new layer

. Save. saves the new layer in the project. Choose a file from the File list box and
choose a layer from the Layer list box.

+  |f youwant to display the results in the view pane, enable the Display saved results
check box.

*  |f youwantto use only the selected records, enable the Dissolve selected shapes
only check box.

12. Inthe Dissolve Method area, enable one of the following options:

Representation Values: removes boundaries between shapes that contain the same
key for the representation of the layer

Attributes: removes boundaries between shapes that contain the same attribute values
13, Click Ok to see the Output result.

Output Result:
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Data Merge

‘You can combine a group of files, regardless of bounds, prejection, data type, or resolution into a
single output file with the Data Merge Wizard. The Data Merge Wizard has three steps: choosing
input layers, setting the output and georeferencing, and setting up output layers,

Steps:

1.  Open Geomatica Focus & then create a new vector layer as shown below,
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2. Create a new polygon by right clicking the new map.

3. Draw any two or more polygon to run merge process.

@
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4,  From the Tools menu, click Data Merge.

5, Inthe File Selector window, select the file you want to add and click Open.
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Set Output file. Choose a file and path from the Name list box.
Choose an output file format from the Qutput format list box.
Set any layer as source layer for projection setup.

Click on Next.

Select layer & Finish,
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11, Select output file & click to Open the Merged result,
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Exercise-5

Aim: To Understand the Symbology and Layout Generation of GIS Data
1. Toperform Zoom in and Zoom out functions
2. Togenerate a layout

Required Data sets
1. GlISdata (use all the vector layers from Raw data folder)

Software Used:
Rolta Geomatica Prime Software

Zoom in and Zoom out
Procedure

From the Start > Programs > select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Toolbar & Rolta Focus will be open.

Bl Geomatica Toolbar V10.3.0 =14

SHEmRBRE

Click on Focus tool from Geomatica Toolbar. Open the Project. Add all the vector layers to the
project and save the project.
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From the main viewer you can:

Click Zoom to Overview to decrease the magnification so the whole image appears in
the viewer.

Click Zoom Interactive and drag a rectangle over the area you are interested in magnifying.
Click Zoom In to increase the magnification by increments.
Click Zoom Qut to decrease the magnification by increments.

Click Zoom 1:1 Image Resolution to adjust the magnification so that one screen pixel
displays one image pixel.

Click to move the image around with the cursor so that you can view all the areas on it

Click Zoom Lock to freeze the view at the current zoom level. Click again unlocks the
view.

Press Page up to increase the magnification by increments or press Page Down to

decrease the magnification by increments,

Press CTRL + Left mouse button to zoom in, & CTRL + Right mouse button to zoom
out.

Click Reload to update the image in the viewer and center it on the cursor.

Click Re-enhance to recalculate the histogram using the range of values existing in the
viewer at the time that you applied the enhancement. The enhancement is recalculated
each time the zoom level is changed by building a histogram with the range of values
available in viewer unless the viewer contains the Re-enhance button.

 Rolta Focus (Trial Version) - Unnamed Project - Unnamed Map
Fle Edt Vew Layer Anlyss Took Hebp
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On the Focus toolbar, click the Zoom In button. The image is enlarged by a factor of 2.

To zoom out, click the Zoom Out button.
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Creating Map Layout

A layoutis a final presentation of data in the form of map which will have following key elements.

e Grid

. MNorth arrow
*  Scale

. Legend

«  Nameof the Map

From the Start > Programs > select Rolta Geomatica > Rolta Geomatica. Rolta Geomatica
Teolbar & Rolta Focus will be open.

¥l Geomatica Toolbar ¥10.3.0 ‘-_ Elil
¢ MR BRI

Click on Focus tool from Geomatica Toolbar. Open the Project. Add all the vector layers to the
project and save the project.
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Display window shows all the vector layers of the project.
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Then go to the Properties of selected Unnamed Map and change the properties as required,
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8 AreaPro perlies

General | Layout  Projection/E stents |

| =] Eoh Mol | [0S o]
Bounds [T -]
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From Legend entry window, Right click on new area feature and select surround tool.

A surround is a collection of graphical elements that gives meaning or clarifies the meaning of
geographical information displayed in a Map. Surround window will have following options to place
on Layout map:
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Focus provides the following surround elements:

Neatline: a visible orinvisible line marking the boundary around the Area beyond which
no data is displayed.

Border: a decorative frame around the Area. It is drawn behind the Area and can be
used as a background

Grid: a pattern of regularly-spaced lines, usually used to indicate coordinates or used
as dividers.

Legend: a table listing and describing the symbols and elements in the Area,
Picture: a graphic such as an image or logo that you place on a Map.

North Arrow: a graphic used to indicate the direction of True Morth, Magnetic North, or
Grid North in relation to an Area.

Scale Bar: a graphical representation of the ratio between a distance in the Area and
the actual distance on the ground.

Title: a name or phrase given to identify the Area.
Paragraph: a block of text, such as an explanatory paragraph, that is placed on the Map,

You can modify the look of the suround elements and save those settings as a Quick Style, which
can be applied to the same type of surround element in the project.
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Output Map Layout for Printing/Publishing
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